File tree 3 files changed +24
-10
lines changed
3 files changed +24
-10
lines changed Original file line number Diff line number Diff line change 1
1
# $NetBSD: Makefile,v 1.3 2014/12/31 13:58:32 thomasklausner Exp $
2
2
3
- DISTNAME = GitPython-3.0.5
3
+ DISTNAME = GitPython-3.1.0
4
4
PKGNAME = ${PYPKGPREFIX}-${DISTNAME:S/GitPython/git/}
5
5
CATEGORIES = devel python
6
6
MASTER_SITES = ${MASTER_SITE_PYPI:=G/GitPython/}
@@ -10,15 +10,32 @@ HOMEPAGE= https://github.com/gitpython-developers/GitPython
10
10
COMMENT = Python library used to interact with Git repositories
11
11
LICENSE = modified-bsd
12
12
13
- DEPENDS+ = ${PYPKGPREFIX}-gitdb2>=2.0.0 :../../wip/py-gitdb2
13
+ DEPENDS+ = ${PYPKGPREFIX}-gitdb-[0-9]* :../../wip/py-gitdb
14
14
DEPENDS+ = git-base>=1.7.0:../../devel/git-base
15
15
16
16
# tests are not intended to be run from pypi distfile,
17
17
# since they operate on GitPython's git repository, see
18
18
# https://github.com/gitpython-developers/GitPython/issues/673
19
19
TEST_DEPENDS+ = ${PYPKGPREFIX}-ddt-[0-9]*:../../devel/py-ddt
20
20
TEST_DEPENDS+ = ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
21
- TEST_DEPENDS+ = ${PYPKGPREFIX}-nose-[0-9]*:../../devel/py-nose
21
+ # tox
22
+ # flake8
23
+ # coverage
24
+ # virtualenv
25
+ # toml
26
+ # py
27
+ # pluggy
28
+ # packaging
29
+ # importlib-metadata
30
+ # filelock
31
+ # pyflakes
32
+ # pycodestyle
33
+ # mccabe
34
+ # entrypoints
35
+ # distlib
36
+ # appdirs
37
+ # pyparsing
38
+ # zipp
22
39
23
40
USE_LANGUAGES = # none
24
41
Original file line number Diff line number Diff line change @@ -187,9 +187,6 @@ ${PYSITELIB}/git/test/fixtures/uncommon_branch_prefix_stderr
187
187
${PYSITELIB}/git/test/lib/__init__.py
188
188
${PYSITELIB}/git/test/lib/__init__.pyc
189
189
${PYSITELIB}/git/test/lib/__init__.pyo
190
- ${PYSITELIB}/git/test/lib/asserts.py
191
- ${PYSITELIB}/git/test/lib/asserts.pyc
192
- ${PYSITELIB}/git/test/lib/asserts.pyo
193
190
${PYSITELIB}/git/test/lib/helper.py
194
191
${PYSITELIB}/git/test/lib/helper.pyc
195
192
${PYSITELIB}/git/test/lib/helper.pyo
Original file line number Diff line number Diff line change 1
1
$NetBSD: distinfo,v 1.4 2017/06/21 09:57:57 adam Exp $
2
2
3
- SHA1 (GitPython-3.0.5. tar.gz) = eb9a5eaa1b63117d92fd6b74e0c3d9b49aea645b
4
- RMD160 (GitPython-3.0.5. tar.gz) = ede9e03a3983748720bee8b311e6d594358ae950
5
- SHA512 (GitPython-3.0.5. tar.gz) = bb47f1dcbe753d7c413f51e48e545b4406b793ad795dd7de3c6aeee313a0ad6409876886cb4b7ebbbddae6a4d2a3f108f403b22133069a61ccb3aef32ab120ad
6
- Size (GitPython-3.0.5. tar.gz) = 433208 bytes
3
+ SHA1 (GitPython-3.1.0. tar.gz) = b1d7b8ebe2e2c5cc4b876eb39e4e27046af5c81b
4
+ RMD160 (GitPython-3.1.0. tar.gz) = faf3d7e7a4449b83296c34bb932f04dc3dd04426
5
+ SHA512 (GitPython-3.1.0. tar.gz) = 6dab8449cc1736d7f58f9788b56bf63cc2bf0f420104d6e010a9624d21f53f5b5d33135bad4d91b40d9543b454be839f8003828ffe512c35a6513c27a2dd4b53
6
+ Size (GitPython-3.1.0. tar.gz) = 430079 bytes
You can’t perform that action at this time.
0 commit comments