Skip to content

Commit cc95dab

Browse files
committed
py-git: update to 3.1.0.
3.1.0 ===== * Switched back to using gitdb package as requirement (`gitdb#59 <https://github.com/gitpython-developers/gitdb/issues/59>`_) 3.0.9 ===== * Restricted GitDB (gitdb2) version requirement to < 4 * Removed old nose library from test requirements Bugfixes -------- * Changed to use UTF-8 instead of default encoding when getting information about a symbolic reference (`#774 <https://github.com/gitpython-developers/GitPython/issues/774>`_) * Fixed decoding of tag object message so as to replace invalid bytes (`#943 <https://github.com/gitpython-developers/GitPython/issues/943>`_) 3.0.8 ===== * Added support for Python 3.8 * Bumped GitDB (gitdb2) version requirement to > 3 Bugfixes -------- * Fixed Repo.__repr__ when subclassed (`#968 <https://github.com/gitpython-developers/GitPython/pull/968>`_) * Removed compatibility shims for Python < 3.4 and old mock library * Replaced usage of deprecated unittest aliases and Logger.warn * Removed old, no longer used assert methods * Replaced usage of nose assert methods with unittest 3.0.7 ===== Properly signed re-release of v3.0.6 with new signature (See `#980 <https://github.com/gitpython-developers/GitPython/issues/980>`_) 3.0.6 ===== | Note: There was an issue that caused this version to be released to PyPI without a signature | See the changelog for v3.0.7 and `#980 <https://github.com/gitpython-developers/GitPython/issues/980>`_ Bugfixes -------- * Fixed warning for usage of environment variables for paths containing ``$`` or ``%`` (`#832 <https://github.com/gitpython-developers/GitPython/issues/832>`_, `#961 <https://github.com/gitpython-developers/GitPython/pull/961>`_) * Added support for parsing Git internal date format (@<unix timestamp> <timezone offset>) (`#965 <https://github.com/gitpython-developers/GitPython/pull/965>`_) * Removed Python 2 and < 3.3 compatibility shims (`#979 <https://github.com/gitpython-developers/GitPython/pull/965>`_) * Fixed GitDB (gitdb2) requirement version specifier formatting in requirements.txt (`#979 <https://github.com/gitpython-developers/GitPython/pull/965>`_)
1 parent 824674a commit cc95dab

File tree

3 files changed

+24
-10
lines changed

3 files changed

+24
-10
lines changed

Diff for: py-git/Makefile

+20-3
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
# $NetBSD: Makefile,v 1.3 2014/12/31 13:58:32 thomasklausner Exp $
22

3-
DISTNAME= GitPython-3.0.5
3+
DISTNAME= GitPython-3.1.0
44
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/GitPython/git/}
55
CATEGORIES= devel python
66
MASTER_SITES= ${MASTER_SITE_PYPI:=G/GitPython/}
@@ -10,15 +10,32 @@ HOMEPAGE= https://github.com/gitpython-developers/GitPython
1010
COMMENT= Python library used to interact with Git repositories
1111
LICENSE= modified-bsd
1212

13-
DEPENDS+= ${PYPKGPREFIX}-gitdb2>=2.0.0:../../wip/py-gitdb2
13+
DEPENDS+= ${PYPKGPREFIX}-gitdb-[0-9]*:../../wip/py-gitdb
1414
DEPENDS+= git-base>=1.7.0:../../devel/git-base
1515

1616
# tests are not intended to be run from pypi distfile,
1717
# since they operate on GitPython's git repository, see
1818
# https://github.com/gitpython-developers/GitPython/issues/673
1919
TEST_DEPENDS+= ${PYPKGPREFIX}-ddt-[0-9]*:../../devel/py-ddt
2020
TEST_DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
21-
TEST_DEPENDS+= ${PYPKGPREFIX}-nose-[0-9]*:../../devel/py-nose
21+
# tox
22+
# flake8
23+
# coverage
24+
# virtualenv
25+
# toml
26+
# py
27+
# pluggy
28+
# packaging
29+
# importlib-metadata
30+
# filelock
31+
# pyflakes
32+
# pycodestyle
33+
# mccabe
34+
# entrypoints
35+
# distlib
36+
# appdirs
37+
# pyparsing
38+
# zipp
2239

2340
USE_LANGUAGES= # none
2441

Diff for: py-git/PLIST

-3
Original file line numberDiff line numberDiff line change
@@ -187,9 +187,6 @@ ${PYSITELIB}/git/test/fixtures/uncommon_branch_prefix_stderr
187187
${PYSITELIB}/git/test/lib/__init__.py
188188
${PYSITELIB}/git/test/lib/__init__.pyc
189189
${PYSITELIB}/git/test/lib/__init__.pyo
190-
${PYSITELIB}/git/test/lib/asserts.py
191-
${PYSITELIB}/git/test/lib/asserts.pyc
192-
${PYSITELIB}/git/test/lib/asserts.pyo
193190
${PYSITELIB}/git/test/lib/helper.py
194191
${PYSITELIB}/git/test/lib/helper.pyc
195192
${PYSITELIB}/git/test/lib/helper.pyo

Diff for: py-git/distinfo

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
$NetBSD: distinfo,v 1.4 2017/06/21 09:57:57 adam Exp $
22

3-
SHA1 (GitPython-3.0.5.tar.gz) = eb9a5eaa1b63117d92fd6b74e0c3d9b49aea645b
4-
RMD160 (GitPython-3.0.5.tar.gz) = ede9e03a3983748720bee8b311e6d594358ae950
5-
SHA512 (GitPython-3.0.5.tar.gz) = bb47f1dcbe753d7c413f51e48e545b4406b793ad795dd7de3c6aeee313a0ad6409876886cb4b7ebbbddae6a4d2a3f108f403b22133069a61ccb3aef32ab120ad
6-
Size (GitPython-3.0.5.tar.gz) = 433208 bytes
3+
SHA1 (GitPython-3.1.0.tar.gz) = b1d7b8ebe2e2c5cc4b876eb39e4e27046af5c81b
4+
RMD160 (GitPython-3.1.0.tar.gz) = faf3d7e7a4449b83296c34bb932f04dc3dd04426
5+
SHA512 (GitPython-3.1.0.tar.gz) = 6dab8449cc1736d7f58f9788b56bf63cc2bf0f420104d6e010a9624d21f53f5b5d33135bad4d91b40d9543b454be839f8003828ffe512c35a6513c27a2dd4b53
6+
Size (GitPython-3.1.0.tar.gz) = 430079 bytes

0 commit comments

Comments
 (0)